peak-linux-driver_7.15.2 on Xenomai-3.0.1

This forum covers PCAN-Linux and Linux development issues concerning our products

peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby kevinjz2010 » Wed 17. Feb 2016, 17:03

Hello,
I want to use the PCAN-PCI Dual Channel(IPEH-002065) on Xenomai-3.0.1-cobalt in Ubuntu14.04.

I tried to compile the peak-linux-driver_7.15.2 with $make RT=XENOMAI, there were many errors.

Then i checked the Xenomai3's MIGRATION manual and found that there were changes have taken place in xenomai3(i.e. struct rtdm_device).

So, i want to know is there any plan to make the peak-linux-driver supporting the xenomai3?

Thank you for helping! :D
kevinjz2010
 
Posts: 4
Joined: Wed 17. Feb 2016, 16:28

Re: peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby G.Lang » Thu 18. Feb 2016, 09:30

Hello kevinjz2010,

at the moment only Xenomai 2.x are supported. It´s planned to support Xenomai 3 with the new driver version 8.x but this new driver version must first run stable at Linux.

best regards
Gunther
G.Lang
Support
Support
 
Posts: 117
Joined: Wed 22. Sep 2010, 14:58
Location: Paradise City

Re: peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby kevinjz2010 » Sun 18. Dec 2016, 10:37

Hi, G.Lang, I have 2 questions, please help me.

1.I want to ask if the most recent peak-linux-driver_8.2 supports the xenomai3 now?

2.Does the PCAN-miniPCIe(supports xenomai or not??) card and the normal PCAN-PCI card have the same performance under xenomai environment?

Thank you!!! :D
kevinjz2010
 
Posts: 4
Joined: Wed 17. Feb 2016, 16:28

Re: peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby G.Lang » Mon 19. Dec 2016, 13:36

Hello,

no, also the coming linux driver 8.3 will not support Xenomai 3.x
It´s planned to support Xenomai 3.x ASAP but it´s a hard work and our main focus is not fixed to Xenomai.


best regards
Gunther
G.Lang
Support
Support
 
Posts: 117
Joined: Wed 22. Sep 2010, 14:58
Location: Paradise City

peak-linux-driver_8.X on Xenomai-3.X

Postby lepalom » Tue 10. Oct 2017, 11:47

Any new about this issue? (support of Xenomai 3.X)
lepalom
 
Posts: 14
Joined: Mon 16. Mar 2015, 18:22

Re: peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby S.Grosjean » Tue 10. Oct 2017, 15:11

Hi,

It is one of our next goals around pcan. We should release v8.5 soon. Next one should include the support of Xenomai 3.0. If you agree, what about being one of our beta testers?

Regards,

Stéphane
User avatar
S.Grosjean
Software Development
Software Development
 
Posts: 143
Joined: Wed 4. Jul 2012, 17:02

Re: peak-linux-driver_7.15.2 on Xenomai-3.0.1

Postby lepalom » Tue 10. Oct 2017, 16:41

Ok, perfect. I can test.

I'm preparing also the debian package.
lepalom
 
Posts: 14
Joined: Mon 16. Mar 2015, 18:22


Return to Linux



cron