PC/104 ISA insmod Unknown symbol in module

This forum covers PCAN-Linux and Linux development issues concerning our products

PC/104 ISA insmod Unknown symbol in module

Postby rplankenhorn » Wed 23. Mar 2011, 20:02

I am trying to install the Linux driver on Ubuntu 10.10 and kernel 2.6.35-28 and I can't get the insmod command that is in the instructions to work. When I run:

sudo insmod pcan.ko type=isa io=0x3F0 irq=10
(I changed the address to 0x3F0.)

I get back:
insmod: error inserting 'pcan.ko': -1 Unknown symbol in module

When I run dmesg, I get back this at the end:

[ 40.069116] pcan: Unknown symbol pcmcia_disable_device (err 0)
[ 40.069811] pcan: Unknown symbol i2c_bit_add_bus (err 0)
[ 40.070767] pcan: Unknown symbol pcmcia_unregister_driver (err 0)
[ 40.073165] pcan: Unknown symbol pcmcia_loop_config (err 0)
[ 40.076390] pcan: Unknown symbol pcmcia_request_io (err 0)
[ 40.076666] pcan: Unknown symbol pcmcia_request_configuration (err 0)
[ 40.079241] pcan: Unknown symbol pcmcia_register_driver (err 0)
[ 40.079884] pcan: Unknown symbol pcmcia_dev_present (err 0)


Any ideas?

Thanks,
Robbie
rplankenhorn
 
Posts: 5
Joined: Wed 23. Mar 2011, 19:57

Re: PC/104 ISA insmod Unknown symbol in module

Postby M.Maidhof » Thu 24. Mar 2011, 10:58

Hi,

which peak-linix-driver version did you use? When your systen does not have a PCMCIA interface, please build the driver without PCC support:

make clean
make NET=NO PCC=NO

best regards

Michael
M.Maidhof
Support
Support
 
Posts: 373
Joined: Wed 22. Sep 2010, 14:00
Location: Darmstadt, Germany

Re: PC/104 ISA insmod Unknown symbol in module

Postby rplankenhorn » Thu 24. Mar 2011, 15:02

Thanks for your response. I am using the 7.1 driver for the PCAN PC/104.

I tried compiling without PCMCIA support and I still get the same error. Here is the output from dmesg:
Code: Select all
[   40.069116] pcan: Unknown symbol pcmcia_disable_device (err 0)
[   40.069811] pcan: Unknown symbol i2c_bit_add_bus (err 0)
[   40.070767] pcan: Unknown symbol pcmcia_unregister_driver (err 0)
[   40.073165] pcan: Unknown symbol pcmcia_loop_config (err 0)
[   40.076390] pcan: Unknown symbol pcmcia_request_io (err 0)
[   40.076666] pcan: Unknown symbol pcmcia_request_configuration (err 0)
[   40.079241] pcan: Unknown symbol pcmcia_register_driver (err 0)
[   40.079884] pcan: Unknown symbol pcmcia_dev_present (err 0)
[   77.801536] pcan: Unknown symbol pcmcia_disable_device (err 0)
[   77.802228] pcan: Unknown symbol i2c_bit_add_bus (err 0)
[   77.803184] pcan: Unknown symbol pcmcia_unregister_driver (err 0)
[   77.805603] pcan: Unknown symbol pcmcia_loop_config (err 0)
[   77.808858] pcan: Unknown symbol pcmcia_request_io (err 0)
[   77.809148] pcan: Unknown symbol pcmcia_request_configuration (err 0)
[   77.811706] pcan: Unknown symbol pcmcia_register_driver (err 0)
[   77.812542] pcan: Unknown symbol pcmcia_dev_present (err 0)
[ 1531.905274] pcan: Unknown symbol pcmcia_disable_device (err 0)
[ 1531.905624] pcan: Unknown symbol i2c_bit_add_bus (err 0)
[ 1531.906447] pcan: Unknown symbol pcmcia_unregister_driver (err 0)
[ 1531.908259] pcan: Unknown symbol pcmcia_loop_config (err 0)
[ 1531.910949] pcan: Unknown symbol pcmcia_request_io (err 0)
[ 1531.911222] pcan: Unknown symbol pcmcia_request_configuration (err 0)
[ 1531.914065] pcan: Unknown symbol pcmcia_register_driver (err 0)
[ 1531.914561] pcan: Unknown symbol pcmcia_dev_present (err 0)
[68788.276147] pcan: Unknown symbol i2c_bit_add_bus (err 0)
rplankenhorn
 
Posts: 5
Joined: Wed 23. Mar 2011, 19:57

Re: PC/104 ISA insmod Unknown symbol in module

Postby rplankenhorn » Thu 24. Mar 2011, 15:14

So I just compiled the driver using this command because I only need ISA support:
Code: Select all
make PAR=NO_PARPORT_SUBSYSTEM USB=NO_USB_SUPPORT PCI=NO_PCI_SUPPORT PCIEC=NO_PCIEC_SUPPORT DNG=NO_DONGLE_SUPPORT PCC=NO_PCCARD_SUPPORT NET=NO_NETDEV_SUPPORT


No I get a different error when I run the insmod command:
Code: Select all
insmod: error inserting 'pcan.ko': -1 Device or resource busy
rplankenhorn
 
Posts: 5
Joined: Wed 23. Mar 2011, 19:57

Re: PC/104 ISA insmod Unknown symbol in module

Postby rplankenhorn » Thu 24. Mar 2011, 15:15

Never mind. I got it working.
rplankenhorn
 
Posts: 5
Joined: Wed 23. Mar 2011, 19:57

Re: PC/104 ISA insmod Unknown symbol in module

Postby M.Maidhof » Mon 28. Mar 2011, 10:31

Hi,

thanks for the info. I am wondering about the I/O address of your PCAN-PC104 card, 0x3F0 is not a valid I/O address for our card. Sure you are using a PCAN card?

best regards

Michael
M.Maidhof
Support
Support
 
Posts: 373
Joined: Wed 22. Sep 2010, 14:00
Location: Darmstadt, Germany

Re: PC/104 ISA insmod Unknown symbol in module

Postby rplankenhorn » Mon 28. Mar 2011, 15:36

Yeah that was the problem. I set it up for 0x300 and was using the wrong address.
rplankenhorn
 
Posts: 5
Joined: Wed 23. Mar 2011, 19:57


Return to Linux



cron