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1 Introduction 

PCAN-Diag is a dedicated device for analysis of various aspects of a 
CAN bus in a mobile environment. Measurements of transmission 
rate, bus load, and termination resistance are possible while 
connected to a live bus. The device also serves as an oscilloscope 
which shows the differential CAN Signal with two channels and has 
various trigger options. A CAN frame can be decoded according to 
the recorded signal course. On a protocol level, messages can be 
displayed as a list, even in symbolic representation. In a similar 
way, transmit lists may be defined and submitted. 

Any user input is done via a push dial. 

PCAN-Diag is normally shipped with a High-speed CAN transceiver, 
different transceiver types may be chosen when ordering (factory 
equipped only). 

1.1 Properties at a Glance 

 High-speed CAN ISO 11898-2, transceivers for other CAN 
transmission standards on request 

 CAN connection D-Sub 9-pin 

 OLED display with 320 x 240 pixels 

 Voltage supply with (rechargeable) batteries or with enclosed 
AC adaptor (no charging function for inserted rechargeable 
batteries). 

 Transmission of CAN messages or message lists 

 Symbolic representation of received CAN messages using CAN 
definition files 
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 Measurement of bus load 

 Measurement of termination at the High-speed CAN bus  
(during operation) 

 Voltage measurement of CAN lines 

 Oscilloscope function for CAN signals with 2 channels and a 
sampling frequency of 20 MHz per channel 

 Various triggering possibilities (CAN ID, error frame, and more) 

 Decoding of CAN messages based on signal trace 

1.2 Scope of Supply 

 PCAN-Diag 

 Plastic case for the device and accessories 

 4 batteries 1.5 V Mignon/AA 

 AC adaptor 

 CD with software and documentation 
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2 Operation 

For operation of the PCAN-Diag go through the sections of this 
chapter in order. 

2.1 CAN Connection (D-Sub) 

Depending on the equipped CAN transceiver, PCAN-Diag's CAN 
socket (9-pin D-Sub) has different pin assignments. 

 
Pin assignment for equipment with High-speed CAN transceiver (standard)  

or Low-speed CAN transceiver 

 
Pin assignment for equipment with Single-wire CAN transceiver  

(see additional notes below) 

If the PCAN-Diag is equipped with a Single-wire CAN transceiver, 
an external supply voltage for the transceiver must be applied to 
pin 1. This voltage lies within 7 to 19 Volts, usually supplied by a car 
battery. 
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The connection of voltage ground (GND) to pins 3 and 6 can be 
switched via Device Settings  > D-Sub GND connection . See 
also section 2.5.4 on page 15. 

The connector's shield is internally connected to voltage ground 
(GND). 

For separate ground connection to other CAN nodes or measuring 
objects an additional 4-millimeter GND socket is provided on the 
back of the device. The internal GND connection is permanent. 

 
GND socket (4 mm) on the back of the device 

2.2 Power Supply 

The PCAN-Diag can be supplied in two ways: 

 externally via the supply socket (section 2.2.1) 

 temporarily by (rechargeable) batteries (section 2.2.2) 

While operation, supply status is shown on the screen's upper 
status bar (section 2.4). 

Note: Inserted rechargeable batteries are not charged during 
external supply. 
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2.2.1 Supply Socket 

Supplying the PCAN-Diag via the designated socket can be done 
using the enclosed AC adaptor or a similar DC source. 

 
Supply socket at the back of the device  

for the connection by a barrel connector 

  
Supply voltage:  

12 V DC (8 - 50 V possible) 
Diameter of barrel connector:  

a = 5.5 mm, b = 2.1 mm;  
minimum length: 11 mm 

2.2.2 Batteries 

For mobile use, the PCAN-Diag can be supplied by (rechargeable) 
batteries: 

 Size: Mignon/AA 

 Quantity: 4 

 Single voltage: nominal 1.2 V or 1.5 V 

The battery compartment is located on the device's bottom side. 
The lid is fixed with two screws. 
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Positions of the screws for the lid of the battery compartment  

(second screw is located beneath the rubber sleeve) 

If an external supply is connected to the device, it will be used as 
primary source. Batteries can stay in the device. 

Note: Inserted rechargeable batteries are not charged during 
external supply. For charging, please remove the empty 
rechargeable batteries and use a separate charger (not part of 
delivery). 
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2.3 Operation Using the Push Dial 

Operating the PCAN-Diag is solely done by a push dial. 

Dial: 
Move selection; alter 
value 

 

Push: 
Power-up device; 
execute selected 
function; exit current 
function 

2.3.1 Powering Up the PCAN-Diag 

Hold down the push dial for at least half a second. 

A splash screen appears for a short moment; then it's replaced by 
the main menu. 

  

Turning off the device is done by selecting Power Off  from the 
main menu. 

Powering-up the device can be blocked by a small knob on the back, 
in order to prevent the batteries from accidental discharging, e.g. 
during transport. 
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Knob on the back of the device for switch interlock of the push dial 

In order to activate the switch interlock, push the knob using a thin 
object. The device now cannot be powered-up with the push dial. 

Unlocking is done likewise: push the small knob again. 
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2.4 Status Display 

When operating the device, in the upper status bar, some symbols 
give information on the voltage supply status and about the CAN 
bus communication. Their meaning is as follows: 

Symbol Meaning 

 The device is connected to an external voltage source (e.g. AC 
adaptor) 

 
 
 
 

The device is supplied by the inserted (rechargeable) batteries. An 
estimation on the remaining capacity is given. 

T  R CAN traffic: T = Transmit, R = Receive 
Blinking: Outgoing/incoming CAN messages 
Green: Regular traffic 
Yellow, red: Erroneous traffic 

act 
pas 
off 

Shows information on the CAN controller's bus status register 
(active, passive, bus off). When entering bus-off state, due to high 
error rate, no further CAN messages are transmitted or received. In 
this case, after fixing the bus problem, a reset of the CAN controller 
should be performed, e.g. in the Receive view with Rst  or the 
Transmit view with Reset . 

L The device operates in observation mode (listen-only). See section 
2.5.3 on page 15. 
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2.5 Device Settings 

In the main menu select Device Settings . The corresponding 
menu offers settings for the device which are explained in the 
following. 

After changing any settings, make them permanent by pressing 
Save&OK . If you want to use the changed settings only temporarily 
(during the current session), press OK . A subsequent session (after 
an off-on cycle) uses the initial settings again. 

Tip: Using Profiles  from the main menu, you can save 
different sets of device settings (profiles) and recall them later 
on demand. See also chapter 3 on page 17. 

2.5.1 CAN Bitrate 

When connecting PCAN-Diag to an “unknown” CAN bus, trans-
mission speed may be detected automatically using menu item 
Detect CAN bitrate . This feature assumes some CAN traffic on 
that bus. 

The manual selection is done with CAN bitrate . Here you can 
select from a list of predefined bit rates. 

To adapt to specific conditions, experts may directly access the CAN 
controller's bus timing registers BTR0 and BTR1. To do so, set the 
item CAN bitrate  to User  and under User CAN bitrate (hex)  
enter a 2-byte value (4 hex digits) being written to the registers. 

Note: CAN decoding as part of the scope function doesn't work 
with user defined CAN bitrates. 

Get further information about setting the CAN bitrate by Bus Timing 
Register on request (contact data: see on page 2). 
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2.5.2 CAN Termination 

A High-speed CAN bus needs to be electrically terminated on both 
ends using resistors of 120 Ω. If the PCAN-Diag is connected to an 
un-terminated end of a CAN bus, you can activate an internal 
resistor by menu item CAN termination . 

Note: This menu item is only available if the device is equipped 
with a High-speed CAN transceiver. 

 Off : Termination is already correctly applied to the High-speed 
CAN bus and the device is connected to a tap within the CAN 
bus. 

 On : The device is connected to a CAN bus whose termination 
isn't complete yet. 

Tip: If you want to check that a connected High-speed CAN bus 
is terminated correctly, you can use the function 
Measurements  > CAN Termination  (see also section 5.2 on 
page 26). 

2.5.3 Observation Mode (Listen-only) 

If the device shall silently watch traffic on the CAN bus without 
influencing it, you can activate the Listen-only mode  (set to On). 
Doing so, the device will neither acknowledge nor transmit CAN 
(error) frames. 

2.5.4 Voltage Ground at the CAN Socket 

Connecting the device's voltage ground to the monitored CAN bus 
may not be useful in some cases. On the scope function differing 
ground levels may cause improper readings, for example. 
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Therefore, you can disconnect the device's voltage ground from D-
Sub connector by software. To do so, set the menu entry D-Sub 
GND connection  to Off . This setting is relevant for pins 3 and 6 of 
the D-Sub connector together (for assignment overview see on 
page 7). The connector shield is permanently connected to the 
device's voltage ground. 

2.5.5 Preserving Battery Sources 

If you run the PCAN-Diag with (rechargeable) batteries, battery 
sources can be preserved by switching off the device automatically 
after a set period of inactivity. You may determine the period with 
Shutdown time (battery) . Setting to Never  causes the device 
to be alive all the time. 

If operating the device with an external supply, for example with the 
enclosed AC adaptor, this setting doesn't have any effect. 

2.5.6 Screensaver 

The brightness of the display will be reduced whenever the device 
is not operated for a certain period. You can set this period with 
Screensaver timeout . 

2.5.7 Acoustic Feedback 

The PCAN-Diag can give acoustic feedback to several events. This 
function is enabled or disabled with Beeper . 
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3 Managing Settings with 
Profiles 

In order to quickly adapt the PCAN-Diag to another operational 
environment, settings can be reloaded from a profile that has been 
saved before. The PCAN-Diag offers five storage locations. 

The following settings are included in the profiles: 

 device settings 

 measurement settings for the D-Sub connection 

 scope settings 

The management is done via the item Profiles  in the main menu. 
Profiles are stored in the device's internal memory. 

Note: Symbol definitions for CAN data are managed indepen-
dently of the settings profiles. See also section 4.2 Symbolic 
View of CAN Data on page 19. 



PCAN-Diag – User Manual 
 

18 

4 Receiving and Transmitting 
CAN Data 

The PCAN-Diag displays all CAN messages on a connected CAN bus 
and transmits user defined CAN messages as well. Representation 
of message content is either in hexadecimal format or symbolic. 
Symbol definitions are transferred via the connected CAN bus. 

4.1 Plain View of CAN Messages 

You can access the plain view of incoming CAN messages via CAN 
Data  > Receive Messages . Representation of CAN data is in 
hexadecimal format. 

Incoming CAN messages are displayed as a list, sorted by CAN ID. 
You can manipulate sorting by clicking on CAN messages. Those 
get priority then, meaning that they are shifted to the top of the list. 
Messages with priority are displayed in orange color. Clicking on 
orange CAN messages takes back priority, meaning that they are 
sorted by CAN ID again. 

Further functions: 

Function Explanation 

Rst Clears the list of incoming CAN messages and resets the CAN 
controller. This might be useful in case of CAN errors. 

Tx1  … Tx7  Activates the selected transmit list. The bottom status bar gives 
information to the selected transmit list. Transmit lists are managed 
in CAN Data  > Manage Transmit Lists . 
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4.2 Symbolic View of CAN Data 

For displaying data of incoming CAN messages in symbolic 
representation, a symbol file must be created on PC and uploaded 
via CAN to the PCAN-Diag then. 

Preconditions for applying symbol definitions to the PCAN-Diag are: 

 Computer with CAN interface of the PCAN series (e.g. PCAN-
USB) 

 CAN cabling with correct termination 

 Windows 7/Vista/XP (32/64-bit) 

 PPCAN-Editor for Windows (setup file is provided on the 
enclosed CD) incl. hardware profile for PCAN-Diag 

4.2.1 Creating Symbol Definitions on the PC 

Symbol definitions are created with the PPCAN-Editor as a so-called 
configuration. Necessary steps for doing so are explained by an 
example with following properties: 

Property Value 

CAN ID (hex) 300 

Symbol name DemoMessage 

Data length (DLC) 2 bytes 

Data (variables) Meter (8 bits) 
Switch1 (1 bit) 
Switch2 (1 bit) 

 

Do the following to create a configuration with symbol 
definitions in the PPCAN-Editor: 

1. Select the menu entry File > New (alternative: ). 

The window CAN Objects appears with the General tab. 
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2. On the General tab select the entry Bus_0 and then the 
menu item CAN Objects > Add a new Symbol (alternative: 

). 

The new entry Symbol1 appears in the tree structure. 

3. Modify the entry by clicking each single field and enter the 
example's values. Make sure to enable the entry (Enable is 
checked). 

 

4. Select the menu item CAN Objects > Add a new Variable 
(alternative: ). 

5. Adjust the entry Var1 (variable Meter). 

6. Repeat the last two steps for the other variables. 

 

7. Select the menu item Edit > New Configuration (alternative: 
), and then, from the opened list the item $1A: PCAN-

Diag. Confirm your selection with OK. 

The CAN Objects window gets the additional tabConfig0 I/O. 

8. Click the tab Config I/O and enter a name for it (e.g. Diag 
Example). 

9. From the General tab select the entry Bus_0, then select the 
menu item CAN Objects > Add Bus to Configuration, and 
subsequently from the displayed list select the entry Diag 
Example I/O. Confirm your selection with OK. 
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10. On the tab Diag Example I/O enable the symbol 
DemoMessage and each variable by checking the boxes in 
the column Enable. 

 

Note: The properties for symbol and variable entries are 
available, if an entry of the corresponding category is selected. 

11. Optionally: Use File > Save (alternative: ) to retain the 
configuration for later use on a data carrier. 

4.2.2 Loading Symbol Definitions onto the PCAN-
Diag 

Symbol definitions are loaded onto the PCAN-Diag via CAN bus. To 
do so, on the PC side the PPCAN-Editor is used, the same tool as 
used to define a configuration with symbol definitions before. 

Do the following to load the symbol definitions onto the PCAN-
Diag: 

1. On the PCAN-Diag select CAN Data  > 
Manage Symbol Files . 

Three list entries are displayed to be loaded with symbol 
definitions. 

2. For one of those three list entries click on Load  which 
initiates transmission via CAN. 

The PCAN-Diag now awaits configuration data from the PC. 
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3. In PPCAN Editor, ensure to be connected to the appropriate 
CAN bus (see bottom status bar, left corner; the figure 
shows an example). 

 

4. On the toolbar select the configuration Diag Example from 
the dropdown list. 

 

5. Select the menu item Transmit > Send Configuration 
(alternative: ). 

The transfer starts and takes a few seconds. The PCAN-
Diag's display shows “Receiving configuration”. 

6. When the transfer is finished, confirm with OK  on the PCAN-
Diag. 

The previously selected list entry now contains the symbol 
definition Diag Example. 

7. Activate that list entry by checking the blue box, thus 
applying the symbol definition to the reception list. 

4.2.3 Opening the Symbolic View 

For displaying CAN data in a symbolic representation, differing 
from the plain view a separate one is used, that you can open with 
CAN Data  > Receive Msgs. as Symbols . As a precondition, 
symbol definitions must be loaded and activated, as explained 
above. 
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4.3 Transmitting CAN Messages 

PCAN-Diag allows creating up to 15 transmit lists with one or more 
CAN messages. Transmit lists may be processed either cyclically or 
once on request. CAN messages within the same list may have an 
individual time offset to each other. 

4.3.1 Creating Transmit Lists 

Do the following to create one or more transmit lists: 

1. Select CAN Data  > Manage Transmit Lists . 

You'll see an overview of the available transmit lists. 

2. Activate an entry below Transmit list  by checking the 
corresponding box. 

A checked entry is marked with a cross [X] . This means, 
that this list is available for transmission and its properties 
can be modified. 

3. Click on the list entry's name in order to edit the properties. 
If the entry hasn't been used yet, the name is unused . 

An edit view is shown. 

4. Modify the list's name by clicking on it. 

5. By default, the list already contains one entry. With the 
mnemonics EID  on the right you can do following actions: 

Mnemonic Action Explanation 

E Edit Shows a CAN message's properties to be 
modified. 

I Insert Adds a new CAN message to the list at the 
given position. Content is taken from the 
current CAN message. 

D Delete Removes this CAN message from the 
transmit list. 
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While editing a CAN message, in addition to the common 
properties the entry Offset  is available. It determines the 
delay in milliseconds after which the CAN message is 
transmitted. The offset refers to the previously transmitted 
CAN message, thus this is a relative designation. 

6. Note the given value for Min. required cycle time  
below the transmit list. This is the lowest cycle time to be 
used for the transmit list. 

You'll set the cycle time for a transmit list later in the 
overview of all transmit lists. 

7. Confirm your modifications to the transmit list with OK . 

8. Set the Cycle time  for each transmit list in the 
corresponding column. The value 0 ms means that the 
transmit list is only initiated manually. 

Note: A cycle time less than the required minimum will cause 
transmission of an incomplete list. The rearmost messages are 
never transmitted. 

9. After creating and enabling transmit lists, scroll down and 
confirm your work with OK . 

4.3.2 Using Transmit Lists 

Do the following to transmit the CAN messages contained in a 
transmit list: 

1. Select CAN Data  > Transmit Messages . 

This shows all available transmit lists. 

2. Activate a transmit list by clicking on it. 
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A list with a defined cycle time will be displayed in orange 
color. It is processed until deactivated by another click on it 
or by power cycling the PCAN-Diag. 

A transmit list without cycle time is only processed once. It 
is always displayed in orange color. 

Tip: You can also activate transmit lists from the plain reception 
view (CAN Data  > Receive Messages), where the first seven 
transmit lists (Tx1  to Tx7) are available. 
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5 Doing Measurements on the 
CAN Bus 

5.1 Bus Load 

Accessible via: Measurements  > Bus Load  

The percentage utilization of the CAN bus with CAN messages is 
shown in a graph over a period of time and is continuously 
updated. 

The graph is put together out of sampling intervals whose duration 
results from the set CAN bitrate and the given number of Samples . 

Per sample value an average and a maximum value of the bus load 
are calculated and shown as bars. 

You can counter a high bus load by 

 raising the bitrate of all involved CAN nodes, or 

 increasing the cycle time of ascertained CAN messages in the 
CAN net in order to reduce emergence (less CAN messages per 
time). 

5.2 CAN Bus Termination 

Accessible via: Measurements  > CAN Termination  

Note: This function is only available, if the PCAN-Diag is 
equipped with a High-speed CAN transceiver. 

A High-speed CAN bus (ISO 11898-2) must be terminated with 
120 Ω on both ends between the CAN lines CAN_L and CAN_H. This 
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measure will prevent signal reflections at the cable ends and a 
correct function of CAN transceivers attached to the CAN bus is 
assured. 

The two termination resistors in parallel result in a total resistance 
of 60 Ω. The measurement of the total resistance provides 
information about a correct CAN bus termination. 

Measurement Interpretation 

~ 60 Ω The termination at the CAN bus is ok in terms of measurement. 
Make sure that the termination resistors are positioned at each end 
of the bus and not, for example, at taps in the middle of the bus. 

~ 120 Ω Only one termination resistor is present. 
Install a further 120-Ohms resistor at the opposite bus end. 

< 45 Ω Too many termination resistors are present at the CAN bus. 
A reason may be that on one bus end both a separate termination 
resistor as well as a CAN node with internal termination are 
installed. 

 

5.3 Voltages on the D-Sub Connector 

Accessible via: Measurements  > D-Sub Connector 

The voltages for each pin of the D-Sub connector can be viewed for 
a rough assessment. 

Note: Because of a delay at voltage measurement due to 
technical reasons, transient voltage fluctuations cannot be 
detected. 

You can configure the display for each pin (Settings): 

 Pin Name  

 Voltage display on/off (Enable) 
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 Range for valid voltages per pin (Min /Max). This range is only 
for display and doesn't have a functional background (beside 
alarm). 

 Generation of an Alarm , if the measured voltage leaves the 
given range (not at voltage spikes). The device setting for alarms 
(Beeper) must be activated. 
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6 Scope Function 

The PCAN-Diag can show the waveform of the CAN lines CAN_L 
and CAN_H, or of the CAN line CAN_SW. Handling the scope 
function is similar to a standard storage scope. 

Additional auxiliary functions are available in order to facilitate the 
interpretation of a signal: 

 Triggering to CAN frames 

 Measuring of a period with cursors 

 Decoding of the waveform 

You can access the scope function via the main menu entry Scope . 

6.1 Using an External Measuring Signal 

The second channel of the scope function can sample an external 
signal for measuring and trigger purposes instead of the CAN_L 
signal. This is routed from the BNC connector on the back of the 
device. 

For an external measuring signal a probe is needed, which is not 
included. Suitable is a standard probe without additional 
electronics, which is operated with setting x1. 

The voltage of an external measuring signal may have a maximum 
of ±50 V. 

In order to establish a separate voltage ground connection between 
the PCAN-Diag and the measuring object, a ground socket (4 mm) is 
provided. 
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Ground socket and BNC connector for probe  

on the back of the device  

To link the second scope channel to the external measuring signal 
do the following setting: 

Scope  > Settings  > Ch2 source  

Setting Measuring range 

Probe (low)  -3 - +15 V 

Probe (high) -10 - +50 V 
 



PCAN-Diag – User Manual 
 

31 

7 Technical Specifications 

Power supply 

Supply voltage Externally via supply socket:  
12 V DC nominal, 8 - 50 V possible 

Internally with 4 (rechargeable) batteries (size 
Mignon/AA):  
4 x 1.5 V or 4 x 1.2 V DC 

Note: The device doesn't charge inserted 
rechargeable batteries. 

Power consumption External supply: 
8 V (min.): 300 mA 
12 V (nom.): 200 mA 
32 V: 83 mA 
50 V (max.): 50 mA 

Operation with batteries: 
5 V: 300 mA 

Single-wire CAN transceiver 
(optional) 

7 - 19 V DC 
via D-Sub connector pin 1 (optionally pin 9) 

 

CAN 

Standard transceiver High-speed CAN ISO 11898-2 (PCA82C251) 

Other transceivers 
(on request) 

Low-speed CAN ISO 11898-3 (TJA1054) 
Single-wire CAN SAE J2411 (TH8056/AU5790) 

Termination High-speed CAN (ISO 11898-2):  
120 Ω switchable via software 

Low-speed CAN (ISO 11898-3):  
none 

Single-wire CAN (SAE J2411):  
none 

Galvanic isolation On request (only with High-speed CAN transceiver) 
 

Display 

Type OLED 

Resolution 320 x 240 pixels 
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Measures 

Size 103 x 58 x 212 (225 with BNC connector) mm  
(W x H x L) 

See also dimension drawing Appendix B on page 34 

Weight 400 g (14.1 oz.) (without batteries) 
 

Environment 

Operating temperature -20 - +60 °C (-4 - +140 °F) 

Temperature for storage 
and transport 

-40 - +80 °C (-40 - +176 °F) 

Relative humidity 15% - 90%, not condensing 

EMC EN 61326-1:2006-10 
EC directive 2004/108/EG 
EN 55011 

Ingress protection  
(IEC 60529) 

IP20 
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Appendix A CE Certificate 
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Appendix B Dimension Drawing 

 
The figure doesn't show the original size;  

dimensions for case without rubber sleeve 
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