Ce site utilise des cookies à des fins d'analyse, de gestion de la connexion au site marchand, au forum et de traitement d’une commande. En continuant à naviguer sur ce site, vous acceptez cette utilisation. Vous trouverez des informations détaillées sur l'utilisation des cookies dans notre politique de confidentialité.

OK Confidentialité

Développement

Les interfaces de programmation d'application listées ci-dessous peuvent être utilisées pour mettre en œuvre une connexion aux bus CAN, CAN FD ou LIN. Pour CAN, il existe des API supplémentaires pour plusieurs normes du secteur automobile. Tous les téléchargements sont disponibles gratuitement. Une interface PC PEAK-System est nécessaire pour la connexion au bus de terrain.

PCAN-Basic API

API pour le développement d‘applications avec les connexions CAN et CAN FD pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PCAN-Basic API (Linux)

API pour le développement d‘applications sur les connexions CAN pour Linux.

Télécharger

PCAN-CCP API

API pour le développement des applications pour la communication avec les calculateurs selon le protocole CAN Calibration Protocol (CCP) pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PCAN-XCP API

API pour le développement des applications pour la communication avec les calculateurs selon le protocole Universal Measurement and Calibration Protocol (XCP) pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PCAN-RP1210 API

L'API RP1210 et la Connexion via le logiciel RP1210 aux Interfaces CAN PEAK. L'installation pour Windows® 10, 8.1 (32/64 bits) inclut : DLLs d'interface, logiciel de test de connexion RP1210 et documentation.

Télécharger

PCAN-PassThru API

L'API Pass-Thru et la Connexion via le logiciel Pass-Thru aux Interfaces CAN PEAK. L'installation pour Windows® 10, 8.1 (32/64 bits) inclut : DLLs d'interface, logiciel de configuration, PCAN-Basic API et PCAN-ISO-TP API. Documentation inclus dans le téléchargement.

Télécharger

PCAN-ISO-TP API

API pour transmettre des paquets de données selon la norme ISO-TP (ISO 15765-2) pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PCAN-UDS API

API pour communiquer avec des dispositifs de commande selon l'UDS (ISO 14229-1) pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PCAN-OBD-2 API

API pour le diagnostic de véhicules selon OBD-2 (ISO 15765-4) pour Windows® 10, 8.1 (32/64 bits).

Télécharger

PLIN-API

API pour le développement d‘applications sur les connexions LIN pour Windows® 10, 8.1 (32/64 bits).

Télécharger


API obsolètes :

Les API énumérées sont obsolètes. Leur utilisation n'est pas recommandée et le support est limité. Il est fort probable qu'elles aient été remplacées par une API améliorée.

PCAN-Light API (obsolète)

API pour le développement d‘applications sur les connexions CAN pour Windows®. Cette API est obsolète. Veuillez utiliser PCAN-Basic à la place.

Télécharger