Nous utilisons des cookies sur notre site web afin de vous fournir le meilleur service possible et d'améliorer encore notre site web. En cliquant sur le bouton "Accepter tout", vous acceptez l'utilisation de tous les cookies. Vous pouvez limiter les cookies utilisés en cliquant sur "Accepter la sélection". Vous trouverez de plus amples informations et une option pour révoquer votre sélection dans notre politique de confidentialité.

Nécessaire :

Ces cookies sont nécessaires pour la fonctionnalité de base. Cela vous permet de vous inscrire sur notre site web et notre forum ou de commander des produits avec notre boutique en ligne.

Statistiques :

Avec ces cookies, nous collectons des données d'utilisation anonymisées pour notre site web. Par exemple, nous pouvons voir quel contenu est intéressant pour nos visiteurs et quelles résolutions sont utilisées. Nous utilisons ces informations pour optimiser notre site web et vous offrir la meilleure expérience utilisateur possible.

Nécessaire
Statistiques

plus

PEAK Hardware Control Panel Applet Version History

Since version 4, the PEAK Hardware Control Panel Applet is a part of our driver setup. It lists available hardware, installed drivers, and APIs. Device IDs and non plug & play hardware can be configured with this tool. After installation you can invoke it via the Windows Control Panel or by entering "PEAKCPL" in the Windows search bar.

2020-09-30 - Version 4.4.1

Bug fixes:

  • If only the PLIN device driver was installed and loaded but the PLinApi.dll was not installed, selecting the Plin_usb.sys device driver entry on the Drivers tab triggered an Access Violation error

2020-07-20 - Version 4.4.0

Improvements:

  • RP1210 page: Supports binding of RP1210-C devices to Device IDs if the installed RP1210-C API DLL is version 3.0 or newer
  • The Device ID of LAN devices can be set on the CAN Hardware page
  • Shows a better error message when the user tries to set the Device ID of an FPGA-based hardware that is currently in use, which is forbidden in PCAN device drivers v4.2.1 and newer

Bug fixes:

  • The LIN Device Manager version on the LIN tab could not be determined since version 4.3.1

2020-04-30 - Version 4.3.1

Bug fixes:

  • If the Device ID of a hardware was changed from outside of the PEAK-Hardware Control Panel and the CAN Hardware tab was not the active tab, the software did not recognize the change of the Device ID and kept showing the previous value
  • The permitted range of Device IDs for PCAN-ExpressCard and PCAN-ExpressCard 34 was incorrectly indicated as 0-FFFFFFFFh, but it is only 0-FFh

2019-08-01 - Version 4.3.0

Improvements:

  • New PCAN-Basic API tab page that allows to reset orphaned PCAN-Basic channels

2018-12-19 - Version 4.2.2

Improvements:

  • LIN driver version information is now shown on the Drivers page if the LIN driver is selected. Previously, the text 'Not available' was displayed
  • If a multi-channel PCAN hardware has different firmware versions for individual channels, e.g. in a PCAN-USB X6, all detected firmware versions are shown in the Firmware column on the CAN Hardware page
  • The hardware serial number is now shown on the CAN Hardware page for PCAN-USB X6 hardware
  • Some minor improvements

2018-01-12 - Version 4.2.1

Improvements:

  • Small improvement for the LIN Manager version information display on the LIN tab

Bug fixes:

  • The application crashed if the online help was opened and then the application was terminated by clicking the close icon in the task bar preview window

2017-09-14 - Version 4.2.0

Improvements:

  • Added API DLL entries for OBD-2, ISO-TP, UDS, and PassThru API on "APIs" tab page

Bug fixes:

  • Storing the "Active Device" selection in the Windows Registry failed in rare cases

2016-05-10 - Version 4.1.1

  • Bug fix: It was not possible to change the Device ID of a PCAN-USB X6 adapter

2016-02-16 - Version 4.1.0

Improvements:

  • Added support for the upcoming PCAN-USB X6
  • SHA-256 code signature

2015-10-05 - Version 4.0.4

  • Bug fix: On 64-bit systems the APIs tab listed the RP1210A 32-bit DLL twice instead of separate 32-bit and 64-bit versions

2015-09-23 - Version 4.0.3

  • Improvement: New tab page "APIs", which shows a summary of installed PEAK API Dlls (32/64-bit)

2015-06-18 - Version 4.0.1

  • Change: LIN hardware IDs are now displayed in hexadecimal format

2015-05-21 - Version 4.0.0

Improvements:

  • Better recognition of installed drivers
  • Requires no separate CAN-API DLL