PPCAN Editor - Triggering functions

This forum covers issues concerning multiple software products.

PPCAN Editor - Triggering functions

Postby Mike B » Wed 5. Apr 2017, 12:41

I'm having a bit of a problem with the way message triggers and function blocks interact.

I have set a message to trigger 1 in the message gateway. In my function blocks, I have an 'If Equals Const' with the cycle time set to 65001 and LinesPerformedIfTrue = 1. Does the line below (which is an 'identity' function), also need the cycle time set to 65001 or 0? Either way the functions are not producing the output I would expect.

The functions do work as I would expect if I set the cycle time of the functions to a time rather than to 65001, but this doesn't quit provide the required output for what i need.
Mike B
 
Posts: 4
Joined: Wed 5. Apr 2017, 12:27

Re: PPCAN Editor - Triggering functions

Postby S.Schott » Thu 6. Apr 2017, 08:29

Hi there.

Your idea for the config is correct, but maybe there is a limitation in the firmware:

We're not yet sure but a first explanation might be:
As soon as the "if" is executed, the trigger is gone,
meaning the following lines with 65001 are never processed.
Maybe such kind of config is then not possible at all (not a bug, simply not forseen).

The responsible firmware developer is investigating on this...
User avatar
S.Schott
Hardware Development
Hardware Development
 
Posts: 29
Joined: Mon 4. Oct 2010, 15:50

Re: PPCAN Editor - Triggering functions

Postby Mike B » Thu 6. Apr 2017, 11:05

Thanks for your response, reading back I probably could have provided more info...

The logic of my function blocks is as follows, all are set with the time set to trigger 1:

If variable A = X (Output to B, linesPerformedIfTrue = 1)
Set variable C to Y
If B = 0 (linesPerformedIfTrue = 1)
Set variable C to B

Variable A is an incoming variable and C is then transmitted on another message.

The second set of function blocks just cleans up the output to 0 if the first line is false.

The output I get at C if I have it set to trigger is always 0 or 1, i.e. always the value of B. If I set it on a cycle time then it works as I would expect.

If I set them all to operate on a cycle rather than a trigger then the results are as expected.
Mike B
 
Posts: 4
Joined: Wed 5. Apr 2017, 12:27

Re: PPCAN Editor - Triggering functions

Postby G.Bohlen » Fri 7. Apr 2017, 09:06

Hello,

- which hardware module do you use (PCAN-MIO, PCAN-Router pro,...)?
- which firmware version do you use? (visible when you do a module detect)

Regards,
Gunnar Bohlen
User avatar
G.Bohlen
Hardware Development
Hardware Development
 
Posts: 32
Joined: Wed 22. Sep 2010, 20:38

Re: PPCAN Editor - Triggering functions

Postby Mike B » Fri 7. Apr 2017, 09:32

It's a Router Pro, Version 1.14, PPCAN version 2.3.
Mike B
 
Posts: 4
Joined: Wed 5. Apr 2017, 12:27

Re: PPCAN Editor - Triggering functions

Postby G.Bohlen » Fri 7. Apr 2017, 10:52

Hello,

we can confirm that this configuration case is not working.
The combination of a conditional function block that is triggerd by the gateway is not possible in the current firmware.
We will add this in a future firmware version.

Regards,
Gunnar Bohlen
User avatar
G.Bohlen
Hardware Development
Hardware Development
 
Posts: 32
Joined: Wed 22. Sep 2010, 20:38

Re: PPCAN Editor - Triggering functions

Postby Mike B » Mon 10. Apr 2017, 11:38

Ok, thanks for the update.

Are you able to give any timescale on when that will happen?

Thanks,
Mike
Mike B
 
Posts: 4
Joined: Wed 5. Apr 2017, 12:27

Re: PPCAN Editor - Triggering functions

Postby U.Wilhelm » Wed 12. Apr 2017, 10:30

Since the problem is not a bug or a function we offer as product feature, we will need some time to add it within one of the next release versions. We could not promise a realistic time line for the new feature.

In principial the combination of a conditional function block that is triggerd by the gateway is not possible in the current firmware.
--------------------------------
PEAK-System Technik
Technical Support Team
support@peak-system.com
-------------------------------
User avatar
U.Wilhelm
Sales & Support
Sales & Support
 
Posts: 1004
Joined: Fri 10. Sep 2010, 18:34
Location: Darmstadt


Return to Software



This website uses cookies for analytics, for logins to the online shop and the forum, and for the handling of an order. By browsing this website you agree to the use of cookies. Detailed information on their use can be found in our privacy policy.

OKPrivacy Policy