Unable to use PCAN-USB X6 with SocketCAN under Linux

6-Channel CAN FD Interface for High-Speed USB 2.0

Unable to use PCAN-USB X6 with SocketCAN under Linux

Postby altran » Wed 22. Feb 2017, 23:11

Is this device supported for use with the Linux SocketCAN drivers?
altran
 
Posts: 14
Joined: Sat 5. Nov 2016, 07:11

Re: Unable to use PCAN-USB X6 with SocketCAN under Linux

Postby M.Maidhof » Thu 23. Feb 2017, 11:35

Hi,

yes, it will be supported with kernel Version 4.9 or higher. If you use an older kernel you have to install our peak-linux-driver 8.3.1 and compile it for NetDev support, or install an out-of-tree kernel driver for the PCAN-USB-X6.

regards

Michael
M.Maidhof
Support
Support
 
Posts: 1192
Joined: Wed 22. Sep 2010, 13:00
Location: Darmstadt, Germany


Return to PCAN-USB X6



This website uses cookies for analytics, for logins to the online shop and the forum, and for the handling of an order. By browsing this website you agree to the use of cookies. Detailed information on their use can be found in our privacy policy.

OKPrivacy Policy