This website uses cookies for analytics, for logins to the online shop and the forum, and for the handling of an order. By browsing this website you agree to the use of cookies. Detailed information on their use can be found in our privacy policy.

OK Privacy Policy

Development

The listed application programming interfaces can be used to implement a connection to CAN, CAN FD, or LIN buses. For CAN, there are additional APIs for several standards from the automotive sector. All downloads are available free of charge. A PC interface from PEAK-System is required for the fieldbus connection.

PCAN-Basic API

API for the development of applications with CAN and CAN FD connections for Windows® 10, 8.1 (32/64-bit).

Download

PCAN-Basic API (Linux)

API for the development of applications with CAN connection for Linux.

Download

PCAN-CCP API

API for the development of software for the communication with ECUs according to the CAN Calibration Protocol (CCP) for Windows® 10, 8.1 (32/64-bit).

Download

PCAN-XCP API

API for the development of software for the communication with ECUs according to the Universal Measurement and Calibration Protocol (XCP) for Windows® 10, 8.1 (32/64-bit).

Download

PCAN-RP1210 API

RP1210 API and connection of RP1210 software to PEAK CAN interfaces. Installation for Windows® 10, 8.1 (32/64-bit) includes interface DLLs, a RP1210 connection test application, and documentation.

Download

PCAN-PassThru API

Pass-Thru API and connection of Pass-Thru software to PEAK CAN interfaces. Installation for Windows® 10, 8.1 (32/64-bit) includes interface DLLs, a configuration software, the PCAN-Basic API, and the PCAN-ISO-TP API. The download also contains the documentation (English).

Download

PCAN-ISO-TP API

API for the transfer of data packages according to ISO-TP (ISO 15765-2) for Windows® 10, 8.1 (32/64-bit).

Download

PCAN-UDS API

API to communicate with control devices according to UDS (ISO 14229-1) for Windows® 10, 8.1 (32/64-bit).

Download

PCAN-OBD-2 API

API for the vehicle diagnostics according to OBD-2 (ISO 15765-4) for Windows® 10, 8.1 (32/64-bit).

Download

PLIN-API

API for the development of applications with LIN connection for Windows® 10, 8.1 (32/64-bit).

Download


Outdated APIs:

The listed APIs are outdated. Their use is not recommended and support is limited. Most likely, they have been replaced by an enhanced API.

PCAN-Light API (outdated)

API for the development of applications with CAN connection for Windows®. This API is outdated. Please use PCAN-Basic instead.

Download